HP 8569B Spectrum Analyer: sweep issues on larger spans, A18 full multiband assy issue

A quick repair story from a kind contributor (Martin, you can find him at www.mjbrf.com).

Symptoms:
(1) I have a unit that generally works OK but has stopped displaying spans above 2MHz/div.

(2) I still get a display on the higher frequency settings e.g. span/div frequency etc etc are displayed at top. However, no trace is displayed.

(3) If I manually sweep using the 100 MHz test signal / comb generator or external frequency source I can still identify the peaks of the signals in the higher span/div settings.

Note that there is a “NARROW” signal used in these machines, which will switch state when span is set above 2 MHz/div. So, best start with looking at all the circuits that are affected by the NARROW signal.

Solution:

The problem was with the A18 (Full multiband assembly board).
When I scoped out the “over sweep blanking signal” (TP1) the signal was high as soon as the unit was set to >= 5MHz/div.
The signal into the board was OK though.

Anyway, I checked U3B opamp and the signal on the output was stuck high on all the higher ranges.

Note:
After inspection of the schematics and downstream circuitry ……
* Removing the multiband board allowed viewing of the higher span/div settings, without the full / multi band and over sweep blanking functionality.
* Isolating the over sweep blanking connector pin from the A18 board to the backplane allowed all ranges to be viewed, but without the over sweep blanking function. Note: The display still looked OK without the over sweep blanking.

Anyway, I changed U3 and U7, but still no luck with the operation. Then I re-checked all diodes and feedback resistors around the opamps.
On inspection, I found that the feedback resistor R29 for U3B (see schematic below) had failed open circuit and was effectively putting U3 into an open loop configuration and thus saturating the output.

The resistor has been replaced and it all seems OK at the moment.

8569b a18 full multi-band assy

This is a quite uncommon fault, on a low-power resistor – maybe a singular fault, or a lot of defective resistors, who can tell for sure.

One thought on “HP 8569B Spectrum Analyer: sweep issues on larger spans, A18 full multiband assy issue”

  1. Hi Simon,
    I have read your blog related to 8569B with great interest, as I have the same machine at home.
    Generally, it was OK (except for HV cascade, I had to build it myself)
    Also, it seems I have the problem with filter or LO driver circuitry.
    When measuring the harmonics generated by built-in comb generator, one of the component (1.8GHz) is clearly visible on the first frequency band, but 10dB lower on the second band (and it should be the same).
    The noise floor has a positive slope when in full span, but it seems the upper band are not calibrated.
    Is there a calibration procedure (simpler than described in service manual) using built in comb generator?
    Thank you in advance!

Leave a Reply to Bojan Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.