Tag Archives: 4-404 transistor

HP 8754A 4 MHz to 1300 MHz Network Analyzer: an analog computer, and a few rusted transistors

There is no specific need for a 1.3 GHz Network Analyzer in my workshop, because there are already several more modern instruments, but this HP 8754A is a real marvel, it was original designed as a “moderately priced, compact” type network analyzer, whatever was considered moderate by HP at the time (maybe the value of two or three small cars?). Finding the offer for a rediculouly low price, for a non-working unit, on Yahoo Japan, I could not resist to place a very moderate bid. Turns out, I was to only bidder, in whole Japan. My original thought was to use it for some experiments, and then, use it a as a source of HP spare parts (there are many FETs, Opamps, transitors, etc. in this machine).

Once the unit arrived, I powered it up, only to find out two things – the -10 Volt and +5 Volt power supplies are not working. And the CRT is very good and sharp. Maybe not many hours of use. Also, the unit is generally clean and in original condition – no other repair attemped. Even the HP instrument feet were included.

The -10 Volt, it required some troubleshooting of the low voltage assembly (corroded transistor legs), see below. The +5 supply, the issue could be traced to a defective TO-3 HP 1820-0430 integrated regulator, alias LM309K.

This regulator is mounted on an aluminum plate in the chassis, with some rather thick ceramic insulator, and what appeared to be only traced of thermal grease. Usually, these are protected against short and overheating, maybe, it was just running a bit hot for year, eventually, accelerating aging and finally triggering natural/random failure with no external even. We will never know, we only know, we have to fix it.

The LM309K tends to become rare and expensive, I still have some back at the Ludwigshafen, Germany workshop, but not here in my temporary Japanese workshop. Checking the offers, I found some very inexpensive LM323K.

The LM323K, it is a very similar device – just higher current capability. It is not critical for the 8754A, the 5 V rail is only loaded by about 0.25-0.3 Amp (as checked with a power supply).

Now, to the corroded transistors. This only seems to affect the boards thats are close to the air inlet, maybe some contamination from ambient air (salt?) is accelerating the effect, related to gold plated steel wire leg transistor. Other transistors have copper, or special alloy wire, but especially the “4-404” and 2N2222A transistors used by HP in the late 1970s seems to be affected by this phenomenon. Not so much in dry countries, but in instruments subject to humind and salty (sea?) conditions here in Japan – just a few km from the cost in most cases.

The 4-404 transistor, alias SS9333, 1854-0404 HP part number, it is a kind of mystery, no data available, and I have seen this part in may Hp instruments, always replacing them with some 4-404 scavenged from part units, etc. But for the 8754A, should we really buy some expensive old HP parts or wait for a long time to go back to Germany to the parts storage? Time for some characterization – found one good, only slightly rusted 4-404, and did some gain, DC performance and frequency response tests at typical currents.

Some basic data could be found – nothing special, the voltage rating rather moderate, and power rating, as well.

Some tests and calculations, it is medium to high gain NPN transistor. BC337-25 or BC337-40 can be valid replacments, I used BC337-25, selected for a gain of 250-300.

High frequency performance is nothing special, it can be easily met by a BC337.

Several 2N2222A are a bit easier to replace – just replaced the TO-18 metal can units with some generic TO-92 2N2222A (or whatever silicon fragments the mass producers put into the 2N2222A case nowadays).

After these initial fixes, the power is up, and the transistors all good. Initial assessment –
(1) front panel “analog computer” is working, some contact cleaner will do the trick, there is no mechanical damage
(2) the CRT will need a filter, it is missing.
(3) the RF output seems to work, at least there is power – need to check with a counter and properly align the linearity, etc.
(4) The VCO and PLL of the receivers seems to have some trouble, but the samplers are working! That’s a relieve.

See below this is a 35 MHz input signal, sampled with the VCO at about 33 MHz, giving a 1 MHz frequency.

So, what is wrong with the PLL? The PLL, it’s purpose is to have a line of a comb generator/multiplier (which is generating the sampler pulses by a step recovery diode) always 1 MHz away from the RF, to give a 1 MHz IF for the R, A and B channels.

This is achieved by first pretuning the VCO, by setting a frequency close to the needed multiple of the VCO, then the PLL is activated and phase lock achieved.

The phase detector, first, I thought is not working, because there is no proper output. But once desoldered, all the transistors tested OK.

The pretune, also this seems to be working, but hold – it is working too well! It is overruling the phase detector.

Further study shows that there are FET switched controlled by a logic signal, via a LM339 comparator. And, as it turns out, the LM339 is dead (both switches on)…

Temporarily fixed the issue by disabling the pre-tune, and enabling the PLL – and, it does lock (albeit, not a fast sweeps – which needs the pretune). But it works of you slowly increase the frequency starting from 0 MHz (this way, you can even measure as 1000 MHz, phase locked!).

After the PLL had been fixed, still some more issues – the R channel detector is not giving a proper output (switching the A8 and A11 boards showed, that the A8 board, which is the same board but used for the A-B channel is working!). Also some issues with the IF switching of the A/B channel, let’s fix this first. The IF switch is part of the A6 assembly mentioned before (which has the VCO and comb generator-diode pulser). To check it, without any fancy extender boards, you can just solder a few wires to the board. I generally prefer solid core telephone wire, this has a very strong and thin insulation, and doesn’t cause shorts easily, because of the single, solid core.

Also here, a dead LM339! Hardwired it for now to conduct the A channel IF.Ordered some LM339N, 10 pcs for USD 1.37.

Now, a few general views, top view:

You can see the card cages, power supply, and the RF sections with oscillators, mixers, samplers.

The bottom side, there are several dangerous DC voltages exposed, don’t touch!

The remaining issue, fixing the R detector and log amplifier, assembly A11. After some probing and thanks to having a working assembly (the A8 A/B detector assembly), the fault could be traced to the log amplifier, and furtunately, not to the transistor pair, which would be very difficult to source or replace, but to the reference amplifier, U2. This is a simple LM301, alias HP 1820-0223.

The LM301, a really early Signetics model! Unfortunately, it is dead, the inputs are somehow leaking negative current.

I already have some LM301 on order, but for the time being, used an old LM301, slightly rusted that I had desoldered recently from a 4191A power supply.

After all these fixed, the unit’s basic functions have all been restored. Sure, there will be through alignement and check, but I will do this once the LM339 and LM301 have made it to Japan. Checked for other issues, by running the units for several hours – very stable. To track the frequency stability, I used a 830 MHz bandpass filter.

Working!!

Also, the instrument originally came with a plastic printed Smith chart that can be attached to the CRT. Wanted to print one, or have one made by photo printing on lightsetting film. But this is more for decorative purposes, and can be done later.