Tag Archives: corrupted eprom

HP 8569A Spectrum Analyzer: A shaky fix

Coming back to an earlier post, 8569A CRT DONOR NEEDED, I was desperately looking for a new CRT for an old 8569A.

After some hints of a kind reader of this blog, I decided to give the box another try, and removed the CRT. There was nothing wrong with the grounding, or the Aquadaq coverage, but at least, there was a sign of defect – a glass chip rattling loose inside the CRT. Turned the CRT with the face to the ground and gave it a few good hits. Reconnected everything (with carefully inserting the CRT back in the box). There result – all working great again. Seems that a piece of glass got stuck in CRT deflection unit, and caused the distortion of the screen. Appears to be a pretty rare defect, but at least, the CRT should be good for now (unless you sit the 8569A on the back feet so that the glas piece can get stuck again in the deflection unit).

Still, some more trouble with this unit:

(1) Rebuild the switch assembly and reference level encoders, about 3 hours of work, and a lot of tiny M1.2 screws, etc.

(2) Some start-up issues: the 8569A would sometimes only start when the “reset” button is pushed. Checked the EPROMs – and, one of them corrupted. Replaced the whole set, just to be sure. These are all TMS2516 EPROMs (let me know if you need the good binary images).

8569a differences

(3) Still more tedious work, replacing the mains filter… many wires… and the mains filter X2 cap.

dav

Now, some quick tests: sensitivity test of all bands, and at 18 GHz, all to specification!

dav

Also checked the power reference, with the best two powder meters at hand, all reading to at least 0.1 dB with no adjustments.

sdr

This repair is done, but please, don’t put this 8569A on its rear feet!