Tag Archives: dead yig oscillator

HP 8753C Network Analyzer: all the dead YIG Oscillators

Having had the non-working HP 8753C on the bench for while, almost getting a bit desperate. The machine is in pristine condition, including the test set, and the CPU board issues were an easy fix. But workings source assemblies, or YTOs, are to no avail. If at all, they are way too expensive. Finally, even got a 2nd 8753C (this unit with option 006 and 002, and with a good display, good to have, in any case) – but same issues there – no signal, the YTO dead.

Here are the two YTOs, both not working at all.

Doing some search on the internet, seems that these oscillators have general lifetime issues, if you want to call it an issue after 30 years… I expect these to work 50 years and longer.

The 8753C series instruments used a variety of YIGs, all pretty similar, but different in their parts number. From hearsay, HP optimized the cost a bit and used these so call economy YIG oscillators. They are a bit suspicious, because they are not hermetically sealed.

The inner circuit, nothing to fix here, all put together with molybdenum substrate, gold wire, and a special transistor that doesn’t seem to provide enough gain any more. Sure I tried to rearrange the sphere (red arrow), and checked all the wires, but no apparent issue. It really seems to be a HF transistor issue inside the microcircuit, at the green arrow.

Be mindful when bidding for any of these 8753 units – they may have all dead or soon-to-die YTOs. And even during their prime time, when spares were still available from HP, the source assemblies 08753-60003 were only available as a whole unit, and certainly HP used to charge several 1000 USD per piece.