Tag Archives: yto unlock

HP 8566B Spectrum Analyzer: A19 board, YTO unlock, bad precision trimmer(s)

Not the first HP 8566B on the bench, and not the first at all showing the famous “YTO unlock” message. Most of these YTO unlock message issues can be traced to defective capacitors, but not this time.

With the 8566B, take my advise, don’t touch any of the assemblies if you aren’t really sure which one is at fault, it is a fairly complex machine. To troubleshoot, a microwave counter is handy, to check the LO frequency.

8566b-repair

Next, the PLL was disengaged by disconnecting the cable from the sampler/LO pll. Still, no good LO frequency output. This leaves two main assemblies to be checked, the LO pretune DAC, and the YTO driver assembly, A19 and A20, respectively.

Quickly traced the issue to the A19 DAC assembly, and luckily enough, had a spare one around, albeit, an older version. After swapping the boards, it was confirmed that the A19 assembly is really the faulty part.

8566b-085660-60164-a19-brd

8566b-085660-60212-a19-brd-old-version

Next – desoldered all the capacitors at one end, but, to my surprise, all useless work, all caps in best working order, even after 25+ years!
Checked various components, and finally, found some issue with the precision trimmers – seems a cold or aged solder joint. To be sure the the fix is as permanent as possible, all the trimmers were removed, the solder connections cleaned, and all installed back in. Easy fix, all working again.

With this unit, there was no intention to do a full calibration, but as an extra service, I checked the power at the reference signal outlet – see below. Quite amazing how accurate, and pretty sure that this unit hadn’t been at a cal lab for at least 15 years….. this is really a superb level of lasting precision and quality, and ingenious engineering.

8566b-pwr-ref-test